We've observed an availability or performance issue with Slack
Incident Report for FireHydrant
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 17:43 UTC
Update
We are still monitoring Slack's status page. It appears Slack is still having some issues with files and image previews, but other services are reportedly back up and running. We have not observed any issues today with modal loading latency so far, but have noticed a few delays with message delivery. To hard reload Slack, please use cmd/ctrl + R . As a reminder, our web UI is not impacted and can be accessed at https://app.firehydrant.io/.
Posted Mar 21, 2024 - 15:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 12:10 UTC
Investigating
Our systems have detected an availability or performance update with Slack and we're investigating the impact. We'll update with further information as it becomes available.

Our web UI is not impacted and can be accessed at https://app.firehydrant.io/

You can also visit Slack's status page at https://status.slack.com/ for more information.
Posted Mar 20, 2024 - 21:23 UTC